Cant see why my Simpbms is Unhappy

Announcement - Help us fight the BOTS! Please report all spam including stuff in your inbox!

bashers

New member
Joined
Oct 1, 2021
Messages
16
I'm still working on my BMS build with an i3 battyery.
On restart i my simpbms is unhappy with its current settings in ESS mode. This can only be cheered up by setting to EV mode and then back again:
@CarelHassink can you enlighten me at all?
BMS Status : ESS Mode : UNhappy: 12

Out:0000 Cont:0000 In:0000 Charge Current Limit : 0 A DisCharge Current Limit : 0 A


Modules: 1 Cells: 12 Strings: 1 Voltage: 47.796V Avg Cell Voltage: 3.983V Low Cell Voltage: 3.981V High Cell Voltage: 3.985V Delta Voltage: 4mV Avg Temp: 21.000C

Module #7 47.80V Cell0: 3.98V Cell1: 3.98V Cell2: 3.98V Cell3: 3.98V Cell4: 3.98V Cell5: 3.98V Cell6: 3.98V Cell7: 3.98V Cell8: 3.98V Cell9: 3.98V Cell10: 3.98V Cell11: 3.98V
Temp 1: 21.00C Temp 2: 21.00C Status: 0x0 Bal: 0x0
0.00mA 89% SOC 83660.01mAh

Firmware Version : 270431

Alarm and Warning Settings Menu
1 - Voltage Warning Offset: 100mV
2 - Cell Voltage Difference Alarm: 200mV
3 - Temp Warning Offset: 5.00 C
4 - Over and Under Voltage Delay: 500 mS

Charging Settings
1 - Cell Charge Voltage Limit Setpoint: 4100mV
2 - Charge Hystersis: 200mV
3 - Pack Max Charge Current: 99.00A
4- Pack End of Charge Current: 10.00A
5- Charger Type: Victron/SMA
6- Charger Can Msg Spd: 100mS
7 - Charger HV Connection: Direct To Battery HV
9 - Charge Current derate Low: 0.00 C

Current Sensor Calibration Menu
c - To calibrate sensor offset
s - Current Sensor Type : Undefined
1 - invert current :0
2 - Pure Voltage based SOC :1
3 - Current Multiplication :1

Contactor and Gauge Settings Menu
1 - PreCharge Timer: 5000mS
2 - PreCharge Finish Current: 100 mA
3 - PWM contactor Hold 0-255 :50
4 - PWM for Gauge Low 0-255 :50
5 - PWM for Gauge High 0-255 :255
6 - ESS Main Contactor or Trip :Main Contactor and Precharge

Debug Settings Menu
Toggle on/off
1 - Can Debug :0
2 - Current Debug :0
3 - Output Check :0
4 - Input Check :0
5 - ESS mode :1
6 - Cells Present Reset :12
7 - Gauge Debug :0
8 - CSV Output :0
9 - Decimal Places to Show :2
b - balance duration :60 S time before starting is 60s
r - reset balance debug

When i set it to EV mode and back to ESS it goes to:

BMS Status : ESS Mode : Happy 12
Out:1110 Cont:0110 In:0000 Charge Current Limit : 60 A DisCharge Current Limit : 100 A


Modules: 1 Cells: 12 Strings: 1 Voltage: 47.795V Avg Cell Voltage: 3.983V Low Cell Voltage: 3.981V High Cell Voltage: 3.987V Delta Voltage: 6mV Avg Temp: 21.000C

Module #7 47.80V Cell0: 3.98V Cell1: 3.98V Cell2: 3.99V Cell3: 3.98V Cell4: 3.98V Cell5: 3.98V Cell6: 3.98V Cell7: 3.98V Cell8: 3.98V Cell9: 3.98V Cell10: 3.98V Cell11: 3.98V
Temp 1: 21.00C Temp 2: 21.00C Status: 0x0 Bal: 0x0
0.00mA 89% SOC 83660.01mAh
 

CarelHassink

Member
Joined
Oct 21, 2017
Messages
159
Mr. Bashers,
not sitting next to you and the system in your workshop,
So here's my 2 cents: perhaps you have corrupted firmware, try flash a fresh new copy on your Teensy, and manually restore settings

best Carel
 
Top