Dala's Leaf buildthread (2015 Nissan Leaf)

Announcement - Help us fight the BOTS! Please report all spam including stuff in your inbox!

Dala

Member
Joined
Feb 16, 2018
Messages
231
So something that I get asked a lot is, "Can you do something about rapidgate?". The short answer is kind-of, but there is something you can do about it.

First what is rapidgate?
In short, rapidgate is overheating of the battery, causing slow charge speeds after the second successive quickcharge. Especially annoying on long trips. Nissan released the 40 and 62kWh packs without any thermal management system, so the battery has to rely on passive cooling, or "Natural air cooling" like Nissan says in their internal documents. This means that it is extremely annoying to take these cars on longer than 500km trips here in Finland. If you are in a hotter area, it gets even worse. Oh, and once the battery gets hot, the heat is very hard to get rid of, so to cool down the leaf you just have to wait until the next day.

Check out this video if you want to learn more on my take on solving rapidgate:
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
I just uploaded a video on how to setup the development environment needed for the CAN-bridges. Might be of use to someone wanting to start coding for this platform. Super nerdy stuff warning!
 

premnissan

New member
Joined
Sep 22, 2020
Messages
2
Hi Dala,
thanks for your valuable points of nissan leaf modifications.
i add 32kw of extra batteries to my nissan leaf 2012 as my battery was degraded to 64%
first when the new extended pack connected, had some odes of insulation. because i have isolated the pack from grounding. once i grounded it, the car start ok and can move, but with the same range indicated in the dash.
i use the original nissan battery control box with the tapping of control wires from original harness. so the precharge system works as same as the pack under the car.
i install a current voltage sensor to the new pack as there is no BMS to it and it will charge from the same onboard charger (i did not had time to check it)
while finishing the wiring with vehicle in off position, but the 12v battery connected and the extra pack was not disconnected, the voltage/amp sensor unit was short circuited. ( one 400v positive line goes to the sensor and the negative shunt is close to it. for some reason that 400v + wire was contact with the negate shunt block and bust up.
now i have the code of B2099, and when i switch on the dash get on, but show I-key ignition not detected,(or similar) appears in the dash board.

what could be the possible issues of grounding the 400v momentarily ? since the control wire was small it bust up immediately, but may be damage some electronic circuits.
please let me know the areas to check to diagnose the fault and correct. i ordered a used IPDM unit as the code says ignition relay open/stuck. but i do not know that is the problem or not.
appreciateyour help,
regards
prem

see below the photo of the bust up sensor unit.

image_orzupr.jpg
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
premnissan said:
Hi Dala,
thanks for your valuable points of nissan leaf modifications.
i add 32kw of extra batteries to my nissan leaf 2012 as my battery was degraded to 64%
first when the new extended pack connected, had some odes of insulation. because i have isolated the pack from grounding. once i grounded it, the car start ok and can move, but with the same range indicated in the dash.
i use the original nissan battery control box with the tapping of control wires from original harness. so the precharge system works as same as the pack under the car.
i install a current voltage sensor to the new pack as there is no BMS to it and it will charge from the same onboard charger (i did not had time to check it)
while finishing the wiring with vehicle in off position, but the 12v battery connected and the extra pack was not disconnected, the voltage/amp sensor unit was short circuited. ( one 400v positive line goes to the sensor and the negative shunt is close to it. for some reason that 400v + wire was contact with the negate shunt block and bust up.
now i have the code of B2099, and when i switch on the dash get on, but show I-key ignition not detected,(or similar) appears in the dash board.

what could be the possible issues of grounding the 400v momentarily ? since the control wire was small it bust up immediately, but may be damage some electronic circuits.
please let me know the areas to check to diagnose the fault and correct. i ordered a used IPDM unit as the code says ignition relay open/stuck. but i do not know that is the problem or not.
appreciateyour help,
regards
prem

see below the photo of the bust up sensor unit.

image_orzupr.jpg

Wow that current measurement sensor got toasted!

Sorry to say but I am no expert when it comes to range extenders and failures of these. I am actually avoiding range-extenders, due to legislation. I know how to make them safer, but I still wouldn't sell a range-extender as a product here.

Sounds like replacing the IPDM is a good start. Maybe make a separate thread about this build, and more can chime in? Especially on the https://www.diyelectriccar.com/ forum!
 

premnissan

New member
Joined
Sep 22, 2020
Messages
2
Hi Dala
thanks for the response. yes i did change the IPDM and clear the codes and it start works.
by the way have you develop a milo meter reading for the complete pack capacity. original plus extender.
if yes, let me know.
i wanted to buy.
as you said i will open a new thread in DIYelectriccar.
thanks
prem
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
premnissan said:
Hi Dala
thanks for the response. yes i did change the IPDM and clear the codes and it start works.
by the way have you develop a milo meter reading for the complete pack capacity. original plus extender.
if yes, let me know.
i wanted to buy.
as you said i will open a new thread in DIYelectriccar.
thanks
prem

No I do not have this type of code. You will have to ask Muxsan, those are the only ones making this properly. Don't know if they are willing to sell code, since it relies on their own current sensor and BMS setup.
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
So I gave the Leaf some well needed protection this weekend. It now has a fighting chance against the salty winter roads. Sorry in advance for poor pictures, I used my mobile phone which has a cracked lens.

Started with removing the underbody plastic. I also re-checked the towbars bolt, and they were all up to the correct torque. This should be done 15k km after towbar has been on the vehicle.
cjCjNpl.jpg


Here is what the undercarriage looks like. Quite OK for a 5 year old vehicle, the plastic has protected it well.
wwU1IKu.jpg


To properly assess what needs to be done, I de-greased the underside and gave it a quick brush
GNFNtBv.jpg


After pressure washing it clean. Be aware that it is extremely dangerous to pressure wash this section. The battery cover flange seal is not rated to withstand pressure, so be careful if you attempt to clean this area with a pressure washer!
XQhi6KY.jpg


After letting the area dry for 24hours, I chose these two products for the rear. Since the area is so well protected, I went with a simple rubber based stonechip. This should prevent any stray salt/gravel flying in there from damaging the thin paint layer that the metal has. I also picked up some cavity protection, to fill all beams with.
KCYVnvf.jpg


After the stonechip was applied, it started to look like this:
Ogc43aQ.jpg


And then the final step was to fill all beams with oil. I went thru all holes all around the vehicle, and sprayed two cans of this stuff. I also filled the bottom of the doorskins with this.
CNKWhfQ.jpg


This should make it possible for the chassis to last to my target of 20-25years. Now I just need to do it on the white Leaf aswell :)
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
Fixing a bug that haunted ZE0 users for >10 months!

So today I got a huge weight of my shoulders. I fixed the last quickcharge bug that affected battery upgraded ZE0 Leafs. Why did it take me so long? Why was it so hard to fix? Lets dive in.

For those of you who don't know, there are significant differences between the AZE0 (2013-2017) and ZE0 (2010-2013) Leaf, when it comes to the software side. Nissan fixed a lot of bugs when they released the newer AZE0 Leaf, and the ZE0 was left behind. The ZE0 has bugs in the lookup tables for charging speed, and don't follow the cell characteristics at all. Some of you might have noticed this, when you fastcharge a standard 24kWh ZE0 Leaf, the charging speed gets FASTER once you heat up the battery on a massive trip. They clearly rushed the firmware on these early cars.

The problem then is that we need to replicate the odd behaviour of the control system when doing battery upgrades. This means slowing down certain periodic CAN messages (e.g. 100ms -> 500ms), cutting down the content, or converting it from one message to another. No big deal, just take lots of logs, analyze the content, and re-format it. It just takes time. Problem is, I haven't had access to a ZE0 Leaf until a month back when I bought one for my company, specifically to be able to make better software solutions.

So what was the bug?
CWegFh7.png

The ZE0 Leaf was not fastcharging properly on older stations. This was a big problem for my customers. Not being able to charge at all stations after getting a 30/40/62kWh pack fitted seemed like a downgrade. Having to plan trips with Plugshare, and inspecting the charger type beforehand was a big hassle. I ofcourse informed all customers about this, and promised a fix however long it would take. It sure took a while...

So why is it so hard to fastcharge a ZE0 Leaf compared to the AZE0? One of the issues is that the early Leaf is NOT CHADEMO COMPATIBLE. You heard that right, the early Leaf is actually Chademo v0.9 only. Why?, It doesn't send SOC% on the QC-CANbus. The charger actually doesn't know what the state of charge is of the car, it has to calculate it from the "Wh current" and "Wh full" value. This is a big problem. Another hack that they did was to always send 60min charging time to the station, and not calculate it in the vehicle. Overall a very cobbled together solution.

The first issue we need to overcome, is that the VCM will then present the two Wh values to the charger. The VCM is locked to 24kWh max, so when you battery upgrade, you will need to spoof this Wh value, and scale it down from 40kWh down to 24kWh when fastcharging. Otherwise the station will see 100% once battery is roughly 55% charged.

The second issue then. The real bug. This is where it took many hours of debugging. During the start of the quickcharge, the older station types will do some handshaking with the car, and agree to what power will be supplied to the battery. The stations simply stated "Communication error"/"Current CMD timeout" on the battery upgraded Leaf. The current commanded got passed thru properly to the VCM, but for some reason the VCM did not apply this value that the battery requested. The solution came from looking at the logs. I'll be switching to some Leaf specific defines, that are available on the Leaf CANbus messages github-repo;

When succesful quickcharging is started

- LB_BPCMAX is initialized to 92.3kW (92.3kW signifies unavailable value, 3FFh)
- Unavailable value for LB_BPCMAX is held until chargers "Charge_StatusTransitionRequest" goes from 3->0->2 (stop,other,quickcharge)
- As soon as quickcharge state is entered, LB_BPCMAX goes to 0kW. This is held for 1s
- After one second has passed, LB_BPCMAX jumps to 20kW, and starts then to ramp according to algorithm


Failed QC: 0x000001dc 8 0x6e 3f 8f fd 01 38 c6 78
Successful QC: 0x000001dc 8 0x6e 3f ff fd e1 09 0d 2d

The problem was in frame.data[4]. 01 insteaf of e1. The 'e' signified 0b111, a maximum value of BPURATE. There is no documentation on this value available, it is simply 0-7 amount of "levels" according to a leaked document. But I know better now, and this value is actually a ramp-rate that the battery sends to the VCM. If the value is low, the VCM will override the current demand that the battery sends, and instead ramp slowly to this value. If you set it to max value, it will instantly follow the demand without ramping. I will be adding this information to my Github page. So after forcing a higher value to the bus, the quickcharging station started to fully function with the older battery upgraded Leafs. Oh, and as a bonus, the slowcharger started to ramp according to reference.

It finally works!
YigqocX.png


I have no clue if you found any interest in this, but this is the culmination of months and months of debugging, sending logs, testing things etc. I would like to thank one customer in particular for helping me with taking logs for this. Huge thanks to Per for having the patience to get thru this. All our vehicles will be better now!

Changelog for v2.32 of CAN-bridge BatteryUpgrade firmware
- All older QC-stations are now working with battery upgraded ZE0 Leafs (Major milestone)
- Slowcharging now ramps faster to target on ZE0
- Quickcharging now ramps faster to target on ZE0 (Example, previous sw took 7min to reach 45kW speed, now this is done in 5seconds)

Dala out
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
The hidden world of chinese battery upgrades

Okay so here is something interesting. Nissan made a Chinese only market BEV, that is called the Nissan Sulphy. Take a look at that picture, it looks so, normal! Why EU doesn't get something like this is perplexing. The english Wikipedia page for Nissan Sulphy doesn't even mention that it comes as an EV version!

vzt433V.png


It seems to share very much of the drivetrain with the Nissan Leaf, so I am piloting the first customer upgrade in China next month. The Sulphy comes in a 38kWh variant. You read that right, it is a 38kWh battery, not a 40kWh battery like in the Leaf. Judging by the pictures I received, there is also some strange access port on the rear stack, very unsure what this is about. Anyone got ideas?

So, as I was saying, I've sent a CAN-bridge to a customer there, that will be testing out putting a Sulphy battery into a Leaf. Exciting!
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
Here is something I've been thinking about for a while, and finally made it. If you like hypermiling, you're in for a good one :D
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
So here it is. Extreme Budget Battery Upgrade. This time my company car, the ZE0 Leaf, gets a 2017 AZE0 30kWh batterypack. This video is not a complete step-by-step video, (there are already great videos on this subject, see EVs Enhanced video for instance) but this video will give you the basic info needed when doing a budget battery upgrade using Dala's CAN-bridge solution. I had a lot of fun making this video :) Enjoy!

 

Menno

Member
Joined
Aug 24, 2017
Messages
48
Hi Dala, do you know about anyone who has tried to replace the pouch cells with cylindrical cells 18650 or 21700?
 

CarelHassink

Member
Joined
Oct 21, 2017
Messages
141

Dala

Member
Joined
Feb 16, 2018
Messages
231
Yes, I do not recommend the 18650 approach at all. Quote from Mux over at MNL;

"Ouch, wire bonded packs - those are notoriously unreliable. Every single cell has a very susceptible point of failure and even single cell failure tends to cause complete pack failure - which has a high likelihood with thousands of cells under the hood.

And you need aggressive thermal management to actually keep those many cells from drifting too far apart. Small differences in the pack tend to magnify over time, see... the Leaf battery packs!

It's doable, but only if you're Tesla. Even then, they had very bad reliability for a few years before nailing down the wire bonding and battery management issues. And for what? It's not like 18650s have a cost advantage in the automotive space these days.

(it is funny to see a bunch of 18650s on top of the original Leaf battery though)"
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
I did some upgrades to my 3d-printer, one of them being a new buildplate. With this, the parts end up looking way more professional. With the powercoated buildplate they get a very nice texture that hides the lines often visible on flat pieces that lay against the bed.

FEsugaF.jpg


Here you can see the aeromod grilleblocker, printed on different bedtypes. The difference is amazing, and really hard to capture on camera, but the parts look waay more expensive :D
 

Dala

Member
Joined
Feb 16, 2018
Messages
231
So I did another maintenance item on my older Leaf, that I already had done on my newer. The reduction gear ATF replacement. This time I decided to record the process, and make a quick DIY video that'll hopefully help someone looking to do the same.

 

Dala

Member
Joined
Feb 16, 2018
Messages
231
So I created a step-by-step video for anyone looking for how to install a CAN-bridge on their ZE0 Nissan Leaf. Quite a boring video, but oh so helpful if you are on the fence about your capabilities to do a battery upgrade / LeafEnhancer install.

 

Dala

Member
Joined
Feb 16, 2018
Messages
231
Yesterday I mounted a 100W LED bar on the Leaf, and made a quick video on the installation process. Wish I'd done this sooner, such an awesome result!

 

Dala

Member
Joined
Feb 16, 2018
Messages
231
So I think this takes the record for the most boring youtube video ever released. 52minutes of me trying to figure out some CAN-data reverse engineering. Please do not watch this, you will go insane from the boredom. Or do watch it, I'm not the police :)

 

Dala

Member
Joined
Feb 16, 2018
Messages
231
So I made a video recently that ties into the prices on the salvage Nissan Leaf battery market, and how much I suck at managing a business. Anyone curios about what it truly costs to upgrade an EV should watch this.
 
Top