Heyo/Daly bms issue.

Announcement - Help us fight the BOTS! Please report all spam including stuff in your inbox!

jimbo1890

New member
Joined
May 3, 2020
Messages
6
Hello All, in January I recieved Heyo/Daly RO5A-GA21 4s LifePo4 bms. I tied it to 4 x100ah Lifepo4 cells. which I use as a UPS for my monitoring pc.

everything seemed ok until I checked the cells with a meter and found a 280mv difference . For the last 2 days I have been trying to get this thing to balance without success.

What I found was first on the bluetooth app I cannot change "type of battery" which shows as "blank" and " cell reference volt" shows "3.6"volts. (second attached pic) Shouldent the cell reference volt be 3.2v?

and using the "PC BMS TOOL" the "battery chemistry" shows "liion" and the "battery chemistry id" shows "002F"

I think this thing is set up for lithium ion instead of lithium iron phosphate.

has anyone else encountered this?



I am hoping there is a different HEX code for lithium iron phosphate if anyone knows it?

I have sent questions and requests for info from the aliexpress vendor but have heard nothing back.

all the safety cutoff parameters seem to work ok. It is just the balancing I can't get working.



thanks

daly1.jpg
daly2.jpg
 

Redpacket

Member
Joined
Feb 28, 2018
Messages
1,302
They likely mean "cell reference voltage" = "cell full"
The "cell volt high protect" number is correct for LiFePo4, if Li-Ion, it would be near 4.2V.
3.2v/cell would be the "nominal" voltage for LiFePo4 chemistry.
Most BMS only have quite small balance currents & it might take a long time to balance.
Did you try measuring current on the balance BMS leads when it should be balancing?
Do you have any loads connected to mid pack terminals, eg 3.2v to 0V or maybe 6.4V to 0V, etc?
 
Top