I need some balance lead help (powerlab 6)

Announcement - Help us fight the BOTS! Please report all spam including stuff in your inbox!

xephonics

New member
Joined
Jun 11, 2018
Messages
14
Hello, I am trying to charge/discharge 8 cells in series.I thought I had the balance leads figured out, but I seems not.

I connected the Black lead to the most negative along with the negative main lead.the lead right by it to the least positive, and the next lead to the 7th least positive, and repeated until the last white lead was landed on the most positive terminal along With the positive main lead

I attached some pics in hope that it helps explain what I mean. Hopefully I just missed something silly.


image_xvekra.jpg



image_tqifup.jpg


Thanks in advance for any help.
 

Korishan

Moderator
Joined
Jan 7, 2017
Messages
6,573
Looks right to me :huh:

You verified the settings to discharge 8 cells, right?
 

xephonics

New member
Joined
Jun 11, 2018
Messages
14
It gave me the bad cell count error, and would not go past checking cells


I checked the voltage on the connector and every wire have increasing voltage, so it is not a bad connection. Do I have the whites reversed? Should the white wire closest to the black have the lowest voltage or the highest?
 

Korishan

Moderator
Joined
Jan 7, 2017
Messages
6,573
Closest to the Black is lowest voltage, then steps up from there. Maybe you don't need that last balance wire? I don't really know as I don't have one of those chargers




Here's a diagram I found in their pdf:http://www.revolectrix.com/support_docs/item_1380.pdf

image_ucrtww.jpg
 

xephonics

New member
Joined
Jun 11, 2018
Messages
14
Ah hah! Thanks. My problem was more that I did not realize the 6 was more than just the version of the charger, it seems to be the max number of batteries in series.
 

Charly144

Member
Joined
Nov 22, 2017
Messages
287
Yes, thats why i was going for 8s and 10s chargers. Unfortunately there is just really very very few 14s out there which i also would have need for...
 
Top