Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using wifi wireless on ethOS
#1
Anything with “ xxxxx “ is entered without the “  ” 
[ENTER] is the enter button on the keyboard

Boot into ethOS with LAN connected *internet connection needed to download files* & compatible wifi card installed, along with keyboard and mouse.
These are two that I had that worked without installing drivers  

In the terminal box on the right of screen lick your mouse button inside the box so you can begin to type.

In the terminal box type the below
1. "sudo apt-get-ubuntu update" [ENTER]
2. "sudo apt-get-ubuntu install network-manager" [ENTER]
3. "Y"[ENTER]
4. "sudo start network-manager" [ENTER]
5. "lspci" (For PCI-slot cards) or "lsusb" (For USB cards) [ENTER]
6. “ifconfig” [ENTER]
7. "sudo ifconfig wlan0 up" [ENTER]
8. "nmcli dev wifi" [ENTER]
9. "sudo apt-get-ubuntu install wpasupplicant" [ENTER]
10. "sudo nmcli d wifi connect <YourRouterName> password <YourRouterPassword> iface wlan0" (without the < >'s) [ENTER]
11. “sudo chmod +777 /etc/rc.local” [ENTER]
12. "Nano /etc/rc.local" [ENTER]
13.  Above all other text in rc.local enter
"start network-manager"
"nmcli d wifi connect <YourRouterName> password <YourRouterPassword> iface wlan0
14.  Ctrl + X to exit
15. "Y" for yes to save
16. [ENTER] to confirm
16. "R" for reboot [ENTER]


Korishan likes this post
Save 10% at Battery Hookup with code 'Powerwalls' Just enter it in checkout www.batteryhookup.com
Reply
#2
Omg I've been looking for this forever! My miner will be on my sailboat soon.
hbpowerwall likes this post
Reply
#3
Hi! Could you update this guide? Or would you be able to tell me what I'm doing wrong? I have the netgear adapter from your guide, and have done every step numerous times. I'm still unable to get it working! My adapter insists it cannot find the SSID. But I know it can because it lists it when I type "sudo iwlist scanning."

Any ideas?
Reply
#4
What do you have your security set to on your router - is it wep, wpa or wpa2 - does the rig see the wifi device ? can you turn a hotspot on your phone and test that as a second test.
Save 10% at Battery Hookup with code 'Powerwalls' Just enter it in checkout www.batteryhookup.com
Reply
#5
This is confirmed and running upgrading from ethOS 1.3.0 > 1.3.2 also updating from ethOS 1.3.1 > 1.3.2 & also fresh install directly onto 1.3.2
Save 10% at Battery Hookup with code 'Powerwalls' Just enter it in checkout www.batteryhookup.com
Reply
#6
I am getting the issue in wifi wireless on ethos and it is not working properly. What should I do to resolve this issue?
Reply
#7
(05-19-2018, 01:16 AM)goeielewe Wrote: Omg I've been looking for this forever! My miner will be on my sailboat soon.

Have you seen what salt air does to electronics?
Reply
#8
I have a DLink Usb DWA-125 and it works but I have some concerns and it might not be ideal.

I followed all the instructions exactly it sees the network and connects, I edit /etc/rc.local above all text like it says, and then upon reboot, it didn’t connect to the internet which I figured out later it takes 5 minutes to connect, and only shows 1 GPU. I remove the edit from /etc/rc.local reboot and still says 1 GPU is shown at the top, unless booted with Ethernet and it shows all and starts immediately. I can type “start network-manager” and it instantly connects to the network, and I can visit websites, without even entering the “nmcli d wifi connect...” , so I guess it remembers the password when first entered from the earlier step. Unless I plug the Ethernet cable back in before booting, it doesn’t show the GPU’s on startup and says starting ethos: finishing boot process and then 5 minutes later, it connects to the internet, and GPUs show up. 10 minutes later, it’s almost at full speed, I’m a few mh/s shy of my normal rate.

Thankfully this miner is pretty stable so if it takes 10 minutes but runs for days then no big deal, but I’m curious why it’s taking so long to start and if there is something I can do to fix that, or if this is the same experience regardless of network adapter, but I doubt it, this seems off.

Thanks for the guide!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)