Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PIP 5048 Inverter fault 52
#1
Hi
I have a 5048 solar inverter that got an error of 09 so I tried to solve the issue using the service manual procedure. So I got 2 IGBIT shorted , so I replaced them all 4 with 4 new ones and then the fault changed to 52 which is (bus voltage is too low ). Can any one help with this fault and what should I check and replace components?


This is the mainboard looks like
Reply
#2
Check for swollen caps, the round ones. It could be your two main ones.
Proceed with caution. Knowledge is Power! Literally! Cool 
Knowledge is Power; Absolute Knowledge is Absolutely Shocking!
Certified 18650 Cell Reclamation Technician

Please come join in general chit-chat and randomness at Discord Chat (channels: general, 3d-printing, linux&coding, 18650, humor, ...)
(this chat is not directly affiliated with SecondLifeStorage; VALID email req'd)
Reply
#3
The MG is pretty new. No warranty or?
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 100kWh LiFePo4 | 20kWh 14s 18650 |  66*260W Poly | ABB S3 and S5 Trip breakers
Upcoming: 14S 18650~30kWh
Reply
#4
I did checked the capacitors they are not poped and they hold a charge

This inverter is out of warranty, it has been working for more than a year , the seller giving 1 y warranty
Reply
#5
The major problem buying cheap Smile They fail and you dont get help Big Grin

I cant help im afraid. I had same issue with my big one and had to replace several boards for alot of money Sad
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 100kWh LiFePo4 | 20kWh 14s 18650 |  66*260W Poly | ABB S3 and S5 Trip breakers
Upcoming: 14S 18650~30kWh
Reply
#6
It isn't cheap , it has been fail because of a spark in battery connection wire , it did run good till I got this spark due to weak connection in dc breaker
Reply
#7
Where are you in the world I fixed the error 09.

Greetings from Germany

More Information to Error 09 fix https://secondlifestorage.com/showthread...265&page=5
raiedzewar likes this post
Reply
#8
the fault 09 is switched to 52 after I replaced the igbits which they got 2 shorted , so i replaced them all (4 pcs). I checked the driver diodes the mosfet and the capacitors seem to be ok comparing its readings with service manual. How should I fix this 52 issue? Can you help me ?
Reply
#9
Its for sure cheap gear. Comparing to certified proper gear MPP cost nothing. Its like 1/3rd of the price and you get what you pay for. I would have loved buying proper gear and would have gotten 5-10 year warranty with support. Unfortunately i cheaped out to and bought above.

For some it works. For some time it work. But when it fails =)

A proper gear does not break down due to a "spark"

And back to topic. Im not sure about error 52 on that model so cant help much but on my modell the software was callibrated towards the driver board and had to reconfig the driver board in the software. Dont know if the new MG modell have this "feature" as well?
raiedzewar likes this post
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 100kWh LiFePo4 | 20kWh 14s 18650 |  66*260W Poly | ABB S3 and S5 Trip breakers
Upcoming: 14S 18650~30kWh
Reply
#10
I started a discussion on how to deal with and solve problems with the PIP devices.
We started there with error 09.
But it is now a collection of all problems hardware from the PIP.

Someone will be able to help you or you will already find the solution there in the news.
also for problem 52.




More information can be found at http://forums.aeva.asn.au/viewtopic.php?f=64&t=6007
raiedzewar likes this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)