Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Batrium Watchmon4 in Node Red
#21
It turns out there was one other ui_chart in one of the flows but I removed it and the bar chart still doesn't show! I've tried a lot of things but no luck!
Reply
#22
(06-16-2020, 08:53 PM)Cell-King Wrote: It turns out there was one other ui_chart in one of the flows but I removed it and the bar chart still doesn't show! I've tried a lot of things but no luck!
Linux or windows?

If windows just uninstall and remove all .node-red folders also in the users\%username%\appdata\Roaming  folders.

reinstall and make sure you only add the node-red dashboard palette.That's all I can think of.

Best of luck
Wolf
For Info Google Drive

Great ABB shunt breaker seller River City Industrial
Great prices and superb service.
 [Image: em2566%20(1)__19172.1521541365.jpg?c=2]

Not your average Wolf       
            Cool
Reply
#23
Cell-King,

Did you ever get your bar chart working?

I tried your code and this is what I came up with.

It seems to work OK on my system. The arrays and everything is working.



Wolf
For Info Google Drive

Great ABB shunt breaker seller River City Industrial
Great prices and superb service.
 [Image: em2566%20(1)__19172.1521541365.jpg?c=2]

Not your average Wolf       
            Cool
Reply
#24
Hi Wolf, Sorry, I'm only seeing this post now! I wasn't able to graph the bar but I made another dashboard instead which sort of shows the same info. Not as pretty, but it works!

  


If anyone was able to fix the

"TypeError: TextDecoder is not a constructor"

please let me know as I still seem to have that project and google doesn't seem to have any further info. I thought I fixed it by adding the Binary Parser but it seems not!
Reply
#25
(06-25-2020, 04:33 PM)Cell-King Wrote: Hi Wolf, Sorry, I'm only seeing this post now! I wasn't able to graph the bar but I made another dashboard instead which sort of shows the same info. Not as pretty, but it works!

If anyone was able to fix the
"TypeError: TextDecoder is not a constructor"

please let me know as I still seem to have that project and google doesn't seem to have any further info. I thought I fixed it by adding the Binary Parser but it seems not!
Cell-King

Have you tried turning off all the debuggers in the whole flow?
There are a bunch of functions  that you don't need and I just disabled them as they were giving me errors. Lots of setup metrics and interface stuff.
Most of them are not needed for the info anyway.
Then I would turn each debugger on and off and see what you get.
Also If you have influx and grafana you can create a nice dashboard with all the data thats pertinent.
Wolf
For Info Google Drive

Great ABB shunt breaker seller River City Industrial
Great prices and superb service.
 [Image: em2566%20(1)__19172.1521541365.jpg?c=2]

Not your average Wolf       
            Cool
Reply
#26
Yes, I have done that, one metric that I can't seem to find due to the errors is if there has been a critical fault event and the "sense" wire on my Watchmon is on. Nice graphs!
Reply
#27
(06-25-2020, 11:28 PM)Cell-King Wrote: ........... one metric that I can't seem to find due to the errors is if there has been a critical fault event..............
Is this what you are looking for?
Wolf
For Info Google Drive

Great ABB shunt breaker seller River City Industrial
Great prices and superb service.
 [Image: em2566%20(1)__19172.1521541365.jpg?c=2]

Not your average Wolf       
            Cool
Reply
#28
Thanks Wolf, I will have a look at that setting when im back at the system. One night the low voltage state was reached and the Batrium tripped the breaker, but the dashboard still said the shunt state was "Idle". I would like to report on that too so I'll do some playing around with that setting when I can.
Reply
#29
(06-26-2020, 11:25 AM)Cell-King Wrote: ................................ One night the low voltage state was reached and the Batrium tripped the breaker, but the dashboard still said the shunt state was "Idle". I would like to report on that too so I'll do some playing around with that setting when I can.
Cell-King
Maybe we need to take this to another thread but for now.....................
So I took a look at my C/D/C cycles of my cells after you mentioned your tripped breaker and I found another issue that perplexes me.
As you can see I trace all my 14 pack voltages in my battery and after doing a 7 day examination I found this.
The yellow circle clearly shows an excessive Vdrop. The green trace(Red Arrow) happens anytime I make an adjustment to the Batrium software so I'm not sure what that is but it is reproducible.

So I investigated the yellow circle timeframe and found this.
A definite report on voltage drop. I wonder if that caused your trip?

A little closer look.
For about 6 min I had no data from the Batrium. Reboot??

I had no other glitches with any other readings from my multitude of sensors at that time. So no Wifi dropout or anything. Also my Batrium is connected to a laptop with USB.
Time range of No Data.

But when the data came back I wonder if the Batrium interpreted the "low V" as a critical event?

Hmm interesting.
Also here is the Snapshot report from 06/22/2020 at 11:55 PM
Code:
System     8093  -  Wolf's
           Wolf's PowIRwall
TimeStamp   6/22/2020 11:55:04 PM  
----------------------------------------------------------------------------------------
System status information
Device Time               Startup                   Ambient  Supply
6/22/2020 11:55:22 PM    5/31/2020  4:39:19 PM       30ºC  53.02v

Versions   Hardware      Firmware      Software        SerialNo
           4.3           4.10          2.0.12          324644513

OpStatus                  AuthMode                  CMU Mode
Discharging               Default                   Normal

SysFaults:  Nil
----------------------------------------------------------------------------------------
Live status information
                   Min @ ID       Max @ ID      Avg     Repeat
CellVolt         3.71v @ 14     3.75v @  4     3.73v      6700
CellTemp           23ºC@ 13       24ºC@  1       23ºC
BypassAmp        0.00A @  0     0.00A @  0
BypassTemp         22ºC@ 14       24ºC@  2
BypSession       0.0mAh@  0     0.4mAh@  4

                Total Overdue  +Final  +Initial  InBypass
NumOfCells         14       0       0         0         0

                 SoC%     Temp     Volt      Amp
Shunt           40.5%     43ºC    52.39v   -10.26A

                   ToEmpty    ToFull
Nom Capacity       57.361     82.639
Est Duration        05:43      45.5d
Recent Consume     10.028      0.000
----------------------------------------------------------------------------------------
Expansion board
Input Run/Idle      = off
Input Charge/Normal = off
----------------------------------------------------------------------------------------
Critical logic
control BattOK state
status  OK
----------------------------------------------------------------------------------------
Charging logic
control ON state
Idle Bypass: off
status  OK
----------------------------------------------------------------------------------------
Discharging logic
control ON state
status  OK
----------------------------------------------------------------------------------------
Thermal Heating Logic
control OFF state
status  OK
----------------------------------------------------------------------------------------
Thermal Cooling Logic
control OFF state
status  OK
----------------------------------------------------------------------------------------
Remote Logic
         ActV    ActA    TgtV    TgtA   state
Charge  0.00v   0.00A  58.10v 148.00A   ON state
Dischg  0.00v   0.00A  47.60v 222.00A   ON state
----------------------------------------------------------------------------------------
Daily Session information
                  Min       Max
CellVolt          3.44      4.06
Thermal             19        29
ShuntSoc           1.0     101.5
ShuntVolt        48.76     57.02
SupplyVolt       49.24     57.48
Critical Events      0

                Charge    Dischg
ShuntPeak        38.15     30.50
Cumulative     151.460   136.578

Banding(hr)   A     B     C     D     E     F     G     H
SoC%        4.0   1.6   1.3   2.4   3.0   2.3   2.1   7.2
Thermal     0.0   0.0   0.0   0.0  23.9   0.0   0.0   0.0
----------------------------------------------------------------------------------------
Cell Node information
  ID  Bypass Initial             Session     Amp     MinV    MaxV    MaxT   BypT   HiT   HiBypT LoV     HiV     BypV    BypA  DatEr Reset  CalV RepCV Serial     HwVers
   1   6/19/2020  4:49:31 PM       0.1 mAh   0.00A   3.72v   3.72v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A    16     2     0  250  316184432  HW6.2 FW2.2 BL2.0
   2   6/22/2020  1:44:26 PM       0.0 mAh   0.00A   3.72v   3.72v   24°C   24°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     0     3     1  250  316176447  HW6.2 FW2.2 BL2.0
   3   6/22/2020  5:05:26 PM       0.1 mAh   0.00A   3.73v   3.73v   24°C   24°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A    10     4     1  250  316111230  HW6.2 FW2.2 BL2.0
   4   6/22/2020  5:30:37 PM       0.4 mAh   0.00A   3.74v   3.75v   24°C   24°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     3     5     0  250  316100340  HW6.2 FW2.2 BL2.0
   5   6/22/2020  5:20:39 PM       0.1 mAh   0.00A   3.72v   3.73v   24°C   24°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     0     6   130  250  316114799  HW6.2 FW2.2 BL2.0
   6   6/22/2020  1:31:40 PM       0.0 mAh   0.00A   3.73v   3.73v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     0     7     0  250  316186980  HW6.2 FW2.2 BL2.0
   7   6/19/2020  2:53:25 PM      17.0 mAh   0.00A   3.72v   3.73v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A    70     8   130  250  316102151  HW6.2 FW2.2 BL2.0
   8   6/19/2020 12:25:50 PM       0.3 mAh   0.00A   3.73v   3.73v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     1     9   129  250  316099104  HW6.2 FW2.2 BL2.0
   9   6/22/2020  3:05:19 PM       0.3 mAh   0.00A   3.72v   3.72v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A   128    10   131  250  316114066  HW6.2 FW2.2 BL2.0
  10   6/22/2020  3:44:34 PM       0.2 mAh   0.00A   3.73v   3.73v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     8    11     0  250  316177575  HW6.2 FW2.2 BL2.0
  11   6/21/2020  2:57:45 PM       0.1 mAh   0.00A   3.72v   3.73v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A   128    12   130  250  316187654  HW6.2 FW2.2 BL2.0
  12   6/18/2020 12:48:09 PM     261.4 mAh   0.00A   3.73v   3.73v   24°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     0    13     7  250  316189745  HW6.2 FW2.2 BL2.0
  13   6/22/2020  3:56:50 PM       0.1 mAh   0.00A   3.72v   3.73v   23°C   23°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A     5    14     0  250  316114117  HW6.2 FW2.2 BL2.0
  14   6/22/2020  5:26:19 PM       0.2 mAh   0.00A   3.71v   3.71v   23°C   22°C   55°C  65°C   3.00v   4.15v   4.08v   0.84A   128    15     3  250  316105276  HW6.2 FW2.2 BL2.0
----------------------------------------------------------------------------------------

This weekend I will be wiring my shunt trip breaker and see if I experience the same at some point.

Wolf
For Info Google Drive

Great ABB shunt breaker seller River City Industrial
Great prices and superb service.
 [Image: em2566%20(1)__19172.1521541365.jpg?c=2]

Not your average Wolf       
            Cool
Reply
#30
Interesting. If it happens when you are syncing the longmons (the "Device Sync" button), the page states that there is no monitoring during that step so maybe the UDP listener is seeing no value or NaN and sending that to Influx?
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)