Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Batrium: software & firmware update
#1
So, in order to resolve another issue with the shunt and canbus randomness I thought I'd better check the versions.

The toolkit updater tells me I've got a newer version than current installed (how is that possible)



The firmware updater fails whilst doing the DOS teensy connect.

Comms is USB or WiFi (fails on both) - there's no internet connectivity issues.

I'll test the other recently arrived WM to see how that fares.

So, a second WM connected, FwVers 4.1 HwVers 4.2 via USB

Software tip (left hand flyout nav) tells me there's a new version available, but as before, the popup tells me I'm running a newer version than latest. 

Start (app updater) tells me INFO app update has started (but progression doesnt advance.

Esp firmware also fails to connect, as with previous WM

Windows 10 pro - groaning, I suppose I better try another laptop.
#2
Because you are running a RC version supplied by Batrium to solve some of the issues. It will be like that until the proper release is relased open to everyone.

IE: Latest public version is 30 what I can see.

(I only checked for WM1 though, Not sure if it differs)
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 83kWh LiFePo4 | 10kWh 14s 18650 |  66*260W Poly
Upcoming: 14S 18650~30kWh | Automatic trip breakers, and alot more
#3
I get same version mismatch issue...
#4
Is this a WM4 problem only ? ( if so, a mention of the version in the op might be a good idea )
___________________________________
18x 300Wp solar off grid and 10x 180Wp solar tracker grid-tie
10KW 3phase hybrid inverter. 40Kwh 18650 storage (for now)
My setup: https://secondlifestorage.com/t-Instant-powerwall
#5
(09-30-2018, 05:59 PM)daromer Wrote: Because you are running a RC version supplied by Batrium to solve some of the issues. It will be like that until the proper release is relased open to everyone.

IE: Latest public version is 30 what I can see.

It was supplied by Batrium, directly from their site, the same version as everyone else should be getting now.

I assumed I was getting the latest public release, not a RC.

(09-30-2018, 06:34 PM)wim Wrote: Is this a WM4 problem only ? ( if so, a mention of the version in the op might be a good idea )

A month or three old WM4 that's been happily running for a while, and another new brand new WM4.

Same results.
#6
The latest public release is v31, linked here
https://www.batrium.com/pages/howto-watc...re-install
#7
(09-30-2018, 07:27 PM)mike Wrote: The latest public release is v31

Yep, that's what I appear to have, I don't know how they do their version control but v31 thinks v30 is the most current.
#8
Then the autoupdater isnt updated. Il ping Jaron to look into it! Because my installs says 30 is latest on the site but on their page he published 31. So its just a mismatch then.
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 83kWh LiFePo4 | 10kWh 14s 18650 |  66*260W Poly
Upcoming: 14S 18650~30kWh | Automatic trip breakers, and alot more
#9
(09-30-2018, 09:23 PM)daromer Wrote: Then the autoupdater isnt updated. Il ping Jaron to look into it! Because my installs says 30 is latest on the site but on their page he published 31. So its just a mismatch then.

So what happens when you do the software update check ?
#10
As I said I can see V30 on WM1. Thats the latest set out on the autoupdater as it looks.
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 83kWh LiFePo4 | 10kWh 14s 18650 |  66*260W Poly
Upcoming: 14S 18650~30kWh | Automatic trip breakers, and alot more


Who read this thread?
96 User(s) read this thread:
hbpowerwall, daromer, Sean, mike, Korishan, PAF, Batrium, Frnandu Martiński, Mike C, jdeadman, wim, wimpie007, watts-on, jesusangel, Stefaan De Ridder, Chiptosser, KtB, Geek, Jon, Bloater, floydR, Chris Jardine, emerca, ChrisD5710, ardenking5, Oz18650, CarelHassink, Filip, Solexx X, Charly144, djuro, Scubasteve04, Lindsaymac1, brwainer, drchips, cat23, HughF, nrm21, rtgunner, outerlimits, EGOksy, phikzel, mbrunton, John Allen, babish, Redpacket, mldee, Oliman, whisperbot, farmerjohn, Cherry67, Scrud, Sholphin02, Walde, Riplash, w0067814, Rick88, michaell, Finihen, yoeri_w, chuckp, DutchDIYPowerwall, Patrick St-Onge, runsnbunsn, deniscroombs, Wolf, Bastler_Ro, |3lksw, camthecam, jeffl98, hellhole, Generic, Bayyn, vieira.pedro, BigDav, dwessels, ajw22, BmoreThor, Rohmad, kevinjaye, oloyeadeniran, OffGridInTheCity, sandroth, zoookii, dealbidz, sparkgap, Tobeabrepper, oel_mangahas, juanjo57, sgrevskott, gpearce52, Moo, Jagath.Madona, doctorjkill, OzfromAUS, bigmac5753

Forum Jump:


Users browsing this thread: 1 Guest(s)