Thread Rating:
  • 4 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Esperyd´s Raspberry PI project
I dont have any 3b+ and wont be getting any. Sorry.

Next version Will be 4 if any
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 83kWh LiFePo4 | 10kWh 14s 18650 |  66*260W Poly
Upcoming: 14S 18650~30kWh | Automatic trip breakers, and alot more
Reply
ok any method or script to install software on upcoming boards like rockpi 4 pi 4b or any upcoming new boards
thanks
Reply
All stuff exist on github.
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 83kWh LiFePo4 | 10kWh 14s 18650 |  66*260W Poly
Upcoming: 14S 18650~30kWh | Automatic trip breakers, and alot more
Reply
(07-08-2019, 03:59 PM)daromer Wrote: Wrong permissions of the files if you have fiddled when them. So when you run them the permissions work out but when the system does it then it fails.
That or the file itself is corrupt. I have seen corruption issues happening on only one user and not all. Dont ask me why but an end bracket missing or something. Must be a bug in the code making that happen.

Though i bet permission on the file.

I tried with your solar_pip.service
and when I start it:
Code:
pi@grafpi /energy-logger/solar-sis/example $ sudo systemctl start solar_pip
pi@grafpi /energy-logger/solar-sis/example $ sudo systemctl status solar_pip
* solar_pip.service - PIP4048 inverter
  Loaded: loaded (/etc/systemd/system/solar_pip.service; enabled)
  Active: activating (auto-restart) (Result: exit-code) since ven. 2019-07-12 16:48:13 CEST; 1min 7s ago
 Process: 8169 ExecStart=/usr/bin/node /energy-logger/solar-sis/example/PIP4084/project.js (code=exited, status=200/CH            DIR)
Main PID: 8169 (code=exited, status=200/CHDIR)
pi@grafpi /energy-logger/solar-sis/example $ ls -l
total 28
-rw-r--r-- 1 root root 4142 d▒c.  11  2017 calls.json
drwxr-xr-x 3 root root 4096 d▒c.  12  2017 MPI10kWHybrid
drwxr-xr-x 3 root root 4096 d▒c.  12  2017 PCM60x
drwxr-xr-x 3 root root 4096 d▒c.  12  2017 PIP4048
drwxr-xr-x 3 root root 4096 juin  29 11:37 PIP5048
-rw-r--r-- 1 root root 1565 d▒c.  11  2017 session.json

It doesn't start

Solar_pip.service
Code:
[Unit]
Description=PIP4048 inverter

[Service]
ExecStart=/usr/bin/node /energy-logger/solar-sis/example/PIP4084/project.js
# Required on some systems
WorkingDirectory=/energy-logger/solar-sis/example/PIP4084/
Restart=always
# Restart service after 10 seconds if node service crashes
RestartSec=120
# Output to syslog
StandardOutput=syslog
StandardError=syslog
SyslogIdentifier=solar_pip
#User=<alternate user>
#Group=<alternate group>
Environment=NODE_ENV=production PORT=1337

[Install]
WantedBy=multi-user.target
Reply
Lagachette are you running My ISO or homemade?

The permission on File is in the One mentioned by the other user
The Ultimate DIY Solar and build place
YouTube / Forum system setup / My webpage  Diy Tech & Repairs

Current: 10kW Mpp Hybrid | 4kW PIP4048 | 2x PCM60x | 83kWh LiFePo4 | 10kWh 14s 18650 |  66*260W Poly
Upcoming: 14S 18650~30kWh | Automatic trip breakers, and alot more
Reply
Yes I run your ISO.
Replacing 4084 by 4048 works much better !!!
Thanks a lot Daniel for your work and your support
Reply
I am trying to connect the dice with a Must 5048 inverter connected via USB but I do not get dice at the moment.
By putting the system manually I get







Reply
(07-14-2019, 04:24 PM)rmonterde Wrote: I am trying to connect the dice with a Must 5048 inverter connected via USB but I do not get dice at the moment.
By putting the system manually I get







USB device unavailable, did you stop the service before running manually? check if you have the file /etc/ttyUSB0, maybe it is ttyUSB1, if so change it in session.json file, sometimes it only doesn't works and need to reboot.

Regards
Reply
hello daromer
i find it googling that if i upgrade my image which is jessei to stretch is work on both 3b and 3b+ i tring first update upgrate to jessie then upgrade to stretch after an hour and dozens of config file permissions some errors its boot 3b+ but its not working properly because some config files cant install properly i think you are the best person to upgrade your own os please upgrade your os thanks
Reply
hello daromer 
first off all thanks for your grade os now i install new sd card first i install update then upgrade then dist-upgrade and then rpi update now your image is working with 3b+ with jessie thanks
Reply


Who read this thread?
100 User(s) read this thread:
hbpowerwall, AZ_Tekkie, Chickey, ShaneE, Minx, daromer, Sean, mike, 18650Shrink, goodnowm, AveRageJoe, BigBen, PaulKennett, Joaquinsfy, SJBW, NiVa, MichelKuenemann, Lux_Gamer, Andreas Kvernes, owitte, opus40, RudyLiPower, lgeo, dakoal, VdVoort4, Glubux, Majorphill, Elwood, coolfx, ruby2, JustJim, Korishan, A + A, PAF, FERCSA, Prahe86, Clisse, Zensay, Franky Beuselinck, Batrium, Darmok, Wattsup, Scepterr, eeesOap, BobinTN, Tristan Timmer, Frnandu Martiński, CrankyCoder, Mike C, Droid126, eAnic, Sabado, jdeadman, charlie246, monsted, camils, Zagy, 2146, wim, wimpie007, ericg, frnandu, typ49, John, Christian, Robert Baumer, Alyas Junior Abdul, Jeremy Choy, 1958 greyhound, Abarth595, Sentinal, Tango47, kktuo, civitou, neilmc, Kaspars Krumins, Off Grid Power wall, Verner A. Møller-jensen, Tychipowerwall, rebelrider.mike, kaits31, gaz, watts-on, Dan Lim, jesusangel, Gimpy_AK, fcbrand, Daggerzz, Hanssing, MetalFang, Fredd, autobd, IronSky, Mark Daniel Olsen, DrkHrs13, tamkov, silverse2m6, kot, quake101, Joost2

Forum Jump:


Users browsing this thread: 8 Guest(s)